Für alle empfohlenen Softwareversionen gilt jeweils das letzte stabile Release.

Anforderungen für Joomla! 3.x

SoftwareEmpfehlungMinimumweietere Informationen
PHP[1]
(Magic Quotes GPC, MB String Overload = off)
(Zlib Compression Support, XML Support, INI Parser Support, JSON Support, Mcrypt Support, MB Language = Default)
5.6 or 7.0 + 5.3.10 https://secure.php.net
Unterstützte Datenbanken:
MySQL[2]
(InnoDB support required)
5.5.3 + 5.1 https://www.mysql.com
SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
Unterstützte Webserver:
Apache[3]
(mit mod_mysql, mod_xml, and mod_zlib)
2.4 + 2.0 https://www.apache.org
Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[4] 7 7 https://www.iis.net

Fußnoten

[1] PHP 5.3.1 wird benötigt für Versionen von 3.0 bis 3.2. Ab 3.3 ist die minimale Version von PHP 5.3.10. Joomla! Versionen ab 3.5 und größer sind PHP 7 kompatibel.

[2] Ab Joomla! 3.5, wird MySQL's `utf8mb4` Zeichensatz unterstützt und ist als Standard definiert für unterstützende MySQL-Server.

[3] Um Suchmaschinenfreundliche URLs (SEO-URLs) verwenden zu können, muss das Apache Module mod_rewrite installiert sein.

[4] Für Microsoft IIS (abhängig vom Setup) hilft ggf. folgendes:

Beitrag übersetzt von https://downloads.joomla.org/technical-requirements

Unser Hostingsponsor

Mittwald Logo